Django & Flask

https://djangopackages.org

https://awesomeopensource.com/project/haiiiiiyun/awesome-django-cn

django version issue

Q1. ImportError: cannot import name ‘python_2_unicode_compatible’ from ‘django.utils.encoding’

第一步
cd #进入根目录
cd .local/lib/python3.6/site-packages
cp six.py django/utils #将six.py拷贝进django/utils/目录下

第二步
将site-packages/haystack/inputs.py 中
from django.utils.encoding import force_text, python_2_unicode_compatible
改为
from django.utils.encoding import force_text
from django.utils.six import python_2_unicode_compatible

Q2: raise ImproperlyConfigured(‘mysqlclient 1.3.13 or newer is required; you have %s.’ % Database.version)

django.core.exceptions.ImproperlyConfigured: mysqlclient 1.3.13 or newer is required; you have 0.9.3.